SaaS Platform Access Disruption

Incident Report for Lucidworks Platform

Resolved

Lucidworks has confirmed the full resolution of this incident. The SaaS Platform interface is once again accessible, and the errors previously encountered at platform.lucidworks.com have been cleared.

The Lucidworks Platform is operating normally for all users. Lucidworks AI and Beacon services remained stable and were not affected throughout this event. There is no lingering impact to platform users or end-user experiences.

A postmortem report will be shared once the internal review is complete.
Posted May 12, 2026 - 17:01 PDT

Monitoring

Engineering has successfully deployed a fix to restore the missing data and has been merged into the production environment. We are now observing a period of stability following these mitigation actions.

The SaaS Platform interface is now accessible, and the previously reported errors have been cleared. Lucidworks AI and Beacon services remain stable and were unaffected throughout the event. No widespread user impact is currently being observed, though we are performing final data validation to ensure all configuration values have been fully restored across the environment.

We are continuing to monitor platform stability and system logs to confirm that all services maintain normal performance levels. We will provide a final update once the monitoring period is complete and the incident is fully resolved.
Posted May 12, 2026 - 16:55 PDT

Identified

Lucidworks has identified that a recent configuration update resulted in the removal of a critical data component within our internal database. This discrepancy is preventing the SaaS Platform interface from retrieving the information required to load correctly, leading to the access errors currently being experienced by users. While services hosted on the Platform remain operational and Lucidworks AI and Beacon services continue to function normally, all SaaS users remain unable to access the SaaS Platform interface.

We are currently implementing a database update to restore the missing components and are repopulating the necessary data from a secure backup to ensure all settings are accurately recovered. Users should refrain from attempting to reconfigure platform settings or applications until access is fully restored. We will provide a further update as soon as more information is available.
Posted May 12, 2026 - 16:23 PDT

Investigating

We are currently investigating an issue affecting the Lucidworks Platform user interface. While services hosted on the Platform remain operational and the Beacon continues to receive signals from client sites, all SaaS users are unable to access the SaaS Platform interface. Users attempting to load platform.lucidworks.com encounter an error stating that applications failed to load and menu items may be unavailable. There is no direct impact to the client’s end-user experience at this time. We are currently working to identify the cause of this disruption and will provide further updates as more information becomes available.
Posted May 12, 2026 - 16:04 PDT
This incident affected: Lucidworks Platform.