Intermittent search request timeouts
Incident Report for Springboard Health
Postmortem

Customers affected by this incident may request a detailed Event Analysis Report via their TAM or through Lucidworks Support.

Posted Apr 18, 2023 - 15:58 UTC

Resolved
Our upstream vendor has deployed a fix for the bug that was impacting some Connected Search customers, and Lucidworks has verified that the issue is now fully resolved.
Posted Apr 18, 2023 - 15:57 UTC
Update
Our upstream vendor has identified the cause of the bug and is working on an urgent fix. In the meantime, we are keeping our mitigation in place and continuing to monitor to ensure continued operations and functionality of Connected Search for all customers. We will provide further updates as soon as we have them.
Posted Apr 13, 2023 - 07:56 UTC
Monitoring
We have confirmed the underlying cause of this issue, and it has been mitigated at this time. A particularly resource-intensive query was found to be impacting the Connected Search backend for all customers by triggering a bug in the underlying data store service. Disabling this query has returned service to normal, and all Connected Search and Springboard UI functionality should be fully restored at this time.

Lucidworks will follow up on a root-cause analysis with the upstream vendor in question, and will update our own findings here as we have more details to share.
Posted Apr 11, 2023 - 20:41 UTC
Identified
We continue to work to fully resolve the source of the query timeouts, while minimizing the impact as much as possible. We believe we have identified the root cause and are now pursuing corrective actions. We'll continue to provide updates as soon as more information is available.
Posted Apr 11, 2023 - 18:54 UTC
Update
We have identified the source of intermittent query failures and occasional timeouts, and are working with an upstream vendor to resolve them. We do not have an ETA for full resolution at this time, but believe that our initial troubleshooting has already lessened both the frequency and severity of these query issues. We will continue to provide updates as the situation develops.
Posted Apr 11, 2023 - 16:19 UTC
Investigating
Some Connected Search requests to the Query API are intermittently timing out, which results in them returning either empty or inconsistent results. This issue is affecting all Connected Search customers, as well as the Experience Optimizer section of the Springboard UI (platform.lucidworks.com).

Lucidworks engineers are investigating the cause of this issue and updates will provided here as soon as we have them.
Posted Apr 11, 2023 - 12:30 UTC
This incident affected: Lucidworks Platform (User Logins & Configuration UI) and Connected Search (US Region Search APIs).