platform.lucidworks.com user interface unavailable

Incident Report for Lucidworks Platform

Postmortem

Summary

On March 6, 2026, at 05:05 UTC, the Lucidworks SaaS Platform experienced a user interface disruption. Users were consistently redirected to a 404 error page when attempting to access platform.lucidworks.com. Other SaaS Platform services, including all search and LWAI functionality, were not affected.

Lucidworks Engineering became aware of the issue at 05:40 UTC and the inaccessibility of the user interface was addressed by 05:45 UTC by reverting the most recently-deployed UI change. At 06:13 UTC, Lucidworks Engineering confirmed that access to the user interface had been fully restored and the platform was operational in its entirety.

Root Cause

The incident was caused by a configuration change to one of our currently in-development UI services that inadvertently affected routing across the entire platform. This change was carried out at 04:57 UTC. Following the code rollout, Lucidworks Engineering became aware that the SaaS Platform user interface was unavailable at 05:40 UTC during routine verification of this deployment.

The deployment configuration setting for that UI service was left blank, which caused the service to claim routing priority for all platform traffic instead of only its intended path. The resulting global path misconfiguration caused the platform to become unavailable and redirected users to a 404 error page.

Reverting this change restored the SaaS Platform to its previous configuration. The incident was verified as resolved at 06:13 UTC.

Lucidworks Actions

Lucidworks will take the following actions as a result of this incident:

  • Establish clear guidelines for infrastructure-sensitive changes
  • Include more explicit warnings to configuration files for critical settings and update internal documentation to highlight high-risk configuration areas

Additionally, Lucidworks will take the following actions to further enhance our ability to detect, withstand, and respond to similar incidents in the future:

  • Enhance automated pre-deployment testing by integrating validation tools that run before any deployment to ensure errors are visible to engineering teams earlier in the process
  • Enhance real-time monitoring for routing anomalies, adding alerts for unexpected traffic patterns, and creating dashboards to provide visibility into platform routing health

The Lucidworks engineering team is committed to ensuring this type of incident does not recur. Lucidworks is implementing multiple layers of prevention, detection, and response improvements. These enhancements will strengthen our platform's resilience and reliability for all customers.

Recommended Client Actions

Lucidworks recommends that clients subscribe to Lucidworks status updates to receive real-time notifications about Lucidworks SaaS Platform incidents. To enable this feature, click Subscribe to Updates on status.lucidworks.com.

Posted Mar 16, 2026 - 15:33 PDT

Resolved

We've confirmed that all platform.lucidworks.com functionality has been restored after reverting the most recently-deployed change. This incident only involved customer access to the SaaS Platform user interface; no search or inference capabilities were affected, and all Platform services remained operational.

A detailed analysis will be posted here as soon as it is available.
Posted Mar 05, 2026 - 22:13 PST

Monitoring

The recent change has been rolled back and UI functionality has been restored. We are monitoring to confirm full recovery.
Posted Mar 05, 2026 - 21:55 PST

Identified

We believe this issue to have been caused by a recently-deployed change for a specific customer UI feature that is currently in development.
Posted Mar 05, 2026 - 21:48 PST

Investigating

We are currently experiencing a disruption of the SaaS Platform user interface. Users are receiving 404 errors when attempting to access platform.lucidworks.com. All other SaaS Platform services remain operational.

There is no direct impact on end-user services or search experiences at this time, but the ability to provision or configure SaaS Platform-based services is affected.

We are actively investigating the issue and taking steps to restore access. We will provide further updates as more information becomes available.
Posted Mar 05, 2026 - 21:05 PST
This incident affected: Lucidworks Platform (User Logins & Configuration).