Connected Search and Experience Optimizer functionality impaired
Incident Report for Springboard Health
Postmortem

Connected Search customers who were affected by this incident may request a detailed Event Analysis via Lucidworks Support.

Posted Jan 12, 2023 - 03:29 UTC

Resolved
An internal routing component of Connected Search had gotten into a stuck state where it could not validate a newly-rotated TLS certificate used to route traffic to the search backend. By restarting this component, we were able to mitigate the issue. We have updated our tooling to force a restart of this component every time the TLS certificate is rotated, in order to avoid a recurrence.
Posted Jan 06, 2023 - 16:15 UTC
Update
We have mitigated the issue, and all search functionality (including both API-based search requests, as well as the ability to use Experience Optimizer in our platform UI) has been restored.
Posted Jan 06, 2023 - 15:55 UTC
Investigating
The Lucidworks Connected Search platform is experiencing an issue with routing traffic that is resulting in failed search query requests. This issue is also affecting the ability to use Experience Optimizer from within the platform web interface.
Posted Jan 06, 2023 - 10:36 UTC
This incident affected: Query APIs (EU Region Search APIs) and Springboard UI.